Month: 四月 2013

mac编译安装automake

mac编译安装handlersocket

报错了…

我直接找到官网的git记录,直接修改源码了….T.T

configure.ac View file @ cc5299f
@@ -4,7 +4,7 @@
#AC_PREREQ([2.63b])
AC_INIT([handlersocket-plugin], [1.0.6], [https://github.com/ahiguti/HandlerSocket-Plugin-for-MySQL/issues])
AC_CONFIG_HEADERS([config.h])
-AM_INIT_AUTOMAKE([-Wall -Werror foreign])
+AM_INIT_AUTOMAKE([-Wall -Wno-extra-portability -Werror foreign])
AC_CONFIG_SRCDIR([libhsclient/fatal.cpp])
AC_CONFIG_MACRO_DIR([m4])

错误:
Running automake …
automake: warnings are treated as errors
/usr/local/share/automake-1.13/am/ltlibrary.am: warning: ‘handlersocket.la’: linking libtool libraries using a non-POSIX
/usr/local/share/automake-1.13/am/ltlibrary.am: archiver requires ‘AM_PROG_AR’ in ‘configure.ac’
handlersocket/Makefile.am:3: while processing Libtool library ‘handlersocket.la’
/usr/local/share/automake-1.13/am/ltlibrary.am: warning: ‘libhsclient.la’: linking libtool libraries using a non-POSIX
/usr/local/share/automake-1.13/am/ltlibrary.am: archiver requires ‘AM_PROG_AR’ in ‘configure.ac’
libhsclient/Makefile.am:7: while processing Libtool library ‘libhsclient.la’

mac 编译安装libtool

mac中编译mysql 5.6

php 路由